Distribuciones Regionales


gnuLinEx Lenix 0.5.2



En esta distribución se encuentran los mismos problemas que en Debian Lenny, la distribución en la que se basa. La distribución Debian Lenny no es totalmente compatible con los drivers instalados desde la página del DNIe y será necesario descargar e instalar varios de los paquetes propios de Debian.

 

Las dependencias concretas que deberá instalar previamente son: libltdl7, pcsc-tools, libopenct1 y libopensc2. Pueden descargarse estos paquetes desde:

        http://packages.debian.org/stable/allpackages

 

La secuencia concreta de paquetes que deben instalarse, contando tanto las dependencias necesarias descargadas como los paquetes extraídos del controlador descargado de la página Web del DNIe, es (la versión de los mismos puede variar):

 

  •     libltdl7_2.2.6a-4_i386.deb
  •     pcsc-tools_1.4.14-1_i386.deb
  •     libopenct2_0.11.7-7_i386.deb
  •     opensc_0.11.7-7_i386.deb
  •     libopenct1_0.6.14-3_i386.deb
  •     libopenct2_0.11.4-5+leny1_i386.deb
  •     libopensc2_0.11.7-7_i386.deb
  •     opensc-dnie_1.4.6-2_i386.deb

 

 

Los paquetes se instalan mediante el procedimiento común de instalación en Debian, por ejemplo:

 

        $ sudo dpkg -i libltdl7_2.2.6a-4_i386.deb

 

 

Si alguno de los paquetes devolviese un error durante la instalación debido a que necesita alguna dependencia, se deberá buscar en la Web indicada esta dependencia e instalarla previamente.

 

Otro problema con el que nos encontramos una vez ha finalizado la instalación es que el lector de tarjetas no reconoce la instalación del DNIe.

 

El problema es debido a que la biblioteca “pcsclite.so.1” se encuentra en una ruta diferente a la especificada en el fichero “opensc.conf”.

 

Para solucionar este problema de forma sencilla, basta con crear un enlace simbólico en el directorio configurado en “opensc.conf” que apunte al fichero correcto, es decir, un enlace simbólico /lib/pcsclite.so.1 que apunte a /usr/lib/pcsclite.so.1. Podemos crear este enlace mediante el comando:

 

        # ln -s /usr/lib/pcsclite.so.1 /lib/pcsclite.so.1

 

 

 

 

Distribuciones Generales


Ubuntu Edgy Eft



La instalación de los controladores del DNI electrónico se debe realizar tal y como se describe en la guía general de instalación. Sin embargo, los repositorios de aplicaciones configurados por defecto en este sistema operativo se han quedado obsoletos y será necesario buscar otros que dispongan de versiones actualizadas de los módulos requeridos para la instalación del controlador del DNIe.

 

Así mismo, en caso de querer instalar Firefox 3 para el uso del DNI electrónico se tendrá que actualizar la librería GTK+ a la versión 2.10 o superior.
Como recomendación general, en caso de disponer de esta versión de la distribución Ubuntu Linux, se aconseja actualizar a versiones más actuales de la misma.

Ubuntu Dapper Drake



La instalación de los controladores del DNI electrónico se debe realizar tal y como se describe en la guía general de instalación. Sin embargo, los repositorios de aplicaciones configurados por defecto en este sistema operativo se han quedado obsoletos y será necesario buscar otros que dispongan de versiones actualizadas de los módulos requeridos para la instalación del controlador del DNIe.

 

Así mismo, en caso de querer instalar Firefox 3 para el uso del DNI electrónico se tendrá que actualizar la librería GTK+ a la versión 2.10 o superior.
Como recomendación general, en caso de disponer de esta versión de la distribución Ubuntu Linux, se aconseja actualizar a versiones más actuales de la misma.

Debian Lenny



La distribución Debian Lenny no es totalmente compatible con los drivers instalados desde la página del DNIe y será necesario descargar e instalar varios de los paquetes propios de Debian.
Las dependencias concretas que deberá instalar previamente son: libltdl7, pcsc-tools, libopenct1 y libopensc2. Pueden descargarse estos paquetes desde:

        http://packages.debian.org/stable/allpackages


La secuencia concreta de paquetes que deben instalarse, contando tanto las dependencias necesarias descargadas como los paquetes extraídos del controlador descargado de la página Web del DNIe, es (la versión de los mismos puede variar):

  • libltdl7_2.2.6a-4_i386.deb
  • pcsc-tools_1.4.14-1_i386.deb
  • libopenct2_0.11.7-7_i386.deb
  • opensc_0.11.7-7_i386.deb
  • libopenct1_0.6.14-3_i386.deb
  • libopenct2_0.11.4-5+leny1_i386.deb
  • libopensc2_0.11.7-7_i386.deb
  • opensc-dnie_1.4.6-2_i386.deb



Los paquetes se instalan mediante el procedimiento común de instalación en Debian, por ejemplo:

        $ sudo dpkg -i libltdl7_2.2.6a-4_i386.deb



Si alguno de los paquetes devolviese un error durante la instalación debido a que necesita alguna dependencia, se deberá buscar en la Web indicada esta dependencia e instalarla previamente.


Otro problema con el que nos encontramos una vez ha finalizado la instalación es que el lector de tarjetas no reconoce la instalación del DNIe.


El problema es debido a que la biblioteca “pcsclite.so.1” se encuentra en una ruta diferente a la especificada en el fichero “opensc.conf”.


Para solucionar este problema de forma sencilla, basta con crear un enlace simbólico en el directorio configurado en “opensc.conf” que apunte al fichero correcto, es decir, un enlace simbólico /lib/pcsclite.so.1 que apunte a /usr/lib/pcsclite.so.1. Podemos crear este enlace mediante el comando:

        # ln -s /usr/lib/pcsclite.so.1 /lib/pcsclite.so.1