¿Cómo actualizo mis repositorios de aplicaciones para descargarme la última versión de los paquetes necesarios para instalar el DNIe?


El método de actualización de su repositorio de aplicaciones puede variar según la distribución y el gestor de paquetes que desee actualizar. Consulte el manual de su herramienta de gestión de paquetes para conocer el método exacto. Los gestores más comunes pueden actualizar sus repositorios mediante los comandos:

 
  • APT-GET: apt-get update
  • APTITUDE: aptitude update
Aún así, la gran mayoría de las distribuciones actuales incorporan entre sus aplicaciones un gestor gráfico de paquetes (Synaptic, Yast, etc.) que facilita la instalación de paquetes y actualizaciones.

En caso de encontrar que los repositorios de su sistema operativo ya no son accesibles puede acceder a la Web de su distribución para conocer cuál es la última versión disponible y las direcciones de sus repositorios.


Si encontrase que no existe ninguna versión superior de su distribución y se ha retirado el soporte, se recomienda encarecidamente que migre a una nueva distribución que ofrezca soporte y en la que la comunidad participe activamente, de ser posible.

 

 

En el listado de controladores de la Web del DNIe aparece una versión específica para mi sistema operativo, pero en el apartado de Instalación del DNIe se me recomienda usar otra versión. ¿Cuál es la adecuada?


La lista de controladores del DNI electrónico se irá ampliando progresivamente. Si en determinado momento aparece una versión específica para su sistema operativo, es recomendable utilizar esa nueva versión.

 

 

Dispongo de una versión antigua de uno de los sistemas operativos listados. ¿Cómo puedo instalar el DNIe?


El proceso de instalación de los controladores del DNIe es similar para todos los sistemas operativos listados, independientemente de su versión. Los problemas que pueden aparecer al utilizar una versión antigua de alguno de estos sistemas es el que no existan repositorios de aplicaciones compatibles con el sistema y que no exista una versión específica del controlador del DNIe. En caso de superar los problemas derivados de la actualización de los repositorios de aplicaciones y la actualización de los módulos requeridos para la instalación del DNIe (proceso dependiente de cada sistema operativo), se recomienda instalar la versión del controlador correspondiente a la versión más próxima del sistema operativo concreto. Esta actuación no garantiza la correcta instalación del DNIe.

Como regla general, siempre se recomienda, tanto por funcionalidad como por seguridad, la migración a la última versión de nuestro sistema operativo. Consulte los manuales y la web de su sistema operativo para llevar a cabo esta tarea.