Instalación del controlador del DNIe


Poder utilizar el DNI electrónico en un sistema operativo OpenSolaris requiere instalar el paquete OpenSC-DNIe correspondiente para Solaris 10.
Este paquete tiene una serie de dependencias que deberemos cubrir: gettext, libintl, libgcc, libtool, ncurses, openssl, zlib. Podemos descargar estos paquetes desde: http://sunfreeware.com.

 

Los comandos para instalar los paquetes son:

 

        $ gunzip gettext-0.14.1-sol10-intel-local.gz
        $ pkgadd -d gettext-0.14.1-sol10-intel-local

 


Deberemos repetir esta operación para cada uno de estos paquetes.

A continuación, ya podemos descargarnos la versión de OpenSC correspondiente a nuestro sistema operativo y arquitectura desde:

http://www.dnielectronico.es/descargas/PKCS11_para_Sistemas_Unix/solaris_10.html


Para la instalación de OpenSC-DNIe deberos descomprimir e instalar:

En arquitectura Intel (32 y 64 bits):

 

En arquitectura SPARC (32 y 64 bits):

 


Para ello, se deberá acceder a un terminal y ejecutar los comandos:

 

        $ gunzip OpenSC-0.11.4-sol10-i86pc-local.gz
        $ pkgadd -d OpenSC-0.11.4-sol10-i86pc-local

 

 

Deberá realizar esta operación con cada uno de los paquetes nombrados anteriormente que se correspondan con la arquitectura del equipo en donde se realiza la instalación.

 

 

Configuración del PKCS#11 del DNI electrónico en Firefox


Para que las aplicaciones tengan acceso al DNIe se deberá enlazar el PKCS#11 de éste desde el repositorio de certificados de Mozilla. Esta operación puede realizarse de Mozilla Firefox.